const regex = /^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:0*)(\\d+(\\.(25|5|75))?)(?:0*)$', 'gm')
const str = `1
01
1.25
01.25
0
0.25
0.50
0.5
0.750
000
0001.111
0001.5
.25
01234
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);