// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$").unwrap();
let string = "1
01
1.25
01.25
0
0.25
0.50
0.5
0.750
000
0001.111
0001.5
.25
01234
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}