#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$"
Local $sString = "1" & @CRLF & _
"01" & @CRLF & _
"1.25" & @CRLF & _
"01.25" & @CRLF & _
"0" & @CRLF & _
"0.25" & @CRLF & _
"0.50" & @CRLF & _
"0.5" & @CRLF & _
"0.750" & @CRLF & _
"000" & @CRLF & _
"0001.111" & @CRLF & _
"0001.5" & @CRLF & _
".25" & @CRLF & _
"01234" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)