$re = '/^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$/m';
$str = '1
01
1.25
01.25
0
0.25
0.50
0.5
0.750
000
0001.111
0001.5
.25
01234
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;