import re
regex = re.compile(r"^(?:0*)(\d+(\.(25|5|75))?)(?:0*)$", flags=re.MULTILINE)
test_str = ("1\n"
"01\n"
"1.25\n"
"01.25\n"
"0\n"
"0.25\n"
"0.50\n"
"0.5\n"
"0.750\n"
"000\n"
"0001.111\n"
"0001.5\n"
".25\n"
"01234\n\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)