$re = '/^(\w+)\R(?=.*?^\1$)/mis';
$str = 'Apple
Banana
TEST
apple
Cherry
banana
bananA
Var
cherry
applE
cherrY';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;