import re
regex = re.compile(r"^(\w+)\R(?=.*?^\1$)", flags=re.MULTILINE | re.IGNORECASE | re.DOTALL)
test_str = ("Apple\n"
"Banana\n"
"TEST\n"
"apple\n"
"Cherry\n"
"banana\n"
"bananA\n"
"Var\n"
"cherry\n"
"applE\n"
"cherrY")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)