#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)"
Local $sString = "the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")