$re = '/the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)/';
$str = 'the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);