import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "the date is\\s*(.*?)\\s*the place is\\s*(.*?)\\s*the people are (.*)";
final String string = "the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}