// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)").unwrap();
let string = "the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}