using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)";
string input = @"the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}