import re
regex = re.compile(r"the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)")
test_str = "the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")