re = /the date is\s*(.*?)\s*the place is\s*(.*?)\s*the people are (.*)/
str = 'the date is February 1st 2000 the place is Los Angeles California the people are Peter Smith and Jon Muir'
# Print the match result
str.match(re) do |match|
puts match.to_s
end