#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?:" & @CRLF & _
" [ ] " & @CRLF & _
" | " & @CRLF & _
" \d " & @CRLF & _
" (?! [ ] )" & @CRLF & _
"){8}" & @CRLF & _
"\d "
Local $sString = "examples of valid strings" & @CRLF & _
"" & @CRLF & _
"00123456789" & @CRLF & _
"kfasdf 34567898asdf" & @CRLF & _
"a 156" & @CRLF & _
"" & @CRLF & _
"and examples of invalid strings" & @CRLF & _
"" & @CRLF & _
"12345 789" & @CRLF & _
"1 9" & @CRLF & _
"a 678a" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")