package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:
[ ]
|
\d
(?! [ ] )
){8}
\d `)
var str = `examples of valid strings
00123456789
kfasdf 34567898asdf
a 156
and examples of invalid strings
12345 789
1 9
a 678a
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}