use strict;
my $str = 'examples of valid strings
00123456789
kfasdf 34567898asdf
a 156
and examples of invalid strings
12345 789
1 9
a 678a
';
my $regex = qr/(?:
[ ]
|
\d
(?! [ ] )
){8}
\d /xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}