$re = '/(?:
[ ]
|
\d
(?! [ ] )
){8}
\d /x';
$str = 'examples of valid strings
00123456789
kfasdf 34567898asdf
a 156
and examples of invalid strings
12345 789
1 9
a 678a
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);