const regex = /(?:
[ ]
|
\d
(?! [ ] )
){8}
\d /g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:
[ ]
|
\\d
(?! [ ] )
){8}
\\d ', 'g')
const str = `examples of valid strings
00123456789
kfasdf 34567898asdf
a 156
and examples of invalid strings
12345 789
1 9
a 678a
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}