import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " [ ] \n"
+ " | \n"
+ " \\d \n"
+ " (?! [ ] )\n"
+ "){8}\n"
+ "\\d ";
final String string = "examples of valid strings\n\n"
+ "00123456789\n"
+ "kfasdf 34567898asdf\n"
+ "a 156\n\n"
+ "and examples of invalid strings\n\n"
+ "12345 789\n"
+ "1 9\n"
+ "a 678a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}