using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:
[ ]
|
\d
(?! [ ] )
){8}
\d ";
string input = @"examples of valid strings
00123456789
kfasdf 34567898asdf
a 156
and examples of invalid strings
12345 789
1 9
a 678a
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}