import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?";
final String string = "https://i.imgur.com/123/123/123.extension\n\n"
+ "https://i.imgur.com/jjwgT7i.jpg\n\n"
+ "https://i.imgur.com/gallery/jjwgT7i.jpg\n\n\n"
+ "// Imgur no gallery\n"
+ "(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/[a-zA-Z0-9]{7}\\.[a-zA-Z]{3,4}\n\n"
+ "// Ingur with gallery\n"
+ "(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}