$re = '/(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?/m';
$str = 'https://i.imgur.com/123/123/123.extension
https://i.imgur.com/jjwgT7i.jpg
https://i.imgur.com/gallery/jjwgT7i.jpg
// Imgur no gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/[a-zA-Z0-9]{7}\\.[a-zA-Z]{3,4}
// Ingur with gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);