import Foundation
let pattern = #"(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://i.imgur.com/123/123/123.extension
https://i.imgur.com/jjwgT7i.jpg
https://i.imgur.com/gallery/jjwgT7i.jpg
// Imgur no gallery
(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/[a-zA-Z0-9]{7}\.[a-zA-Z]{3,4}
// Ingur with gallery
(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)