use strict;
my $str = 'https://i.imgur.com/123/123/123.extension
https://i.imgur.com/jjwgT7i.jpg
https://i.imgur.com/gallery/jjwgT7i.jpg
// Imgur no gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/[a-zA-Z0-9]{7}\\.[a-zA-Z]{3,4}
// Ingur with gallery
(?:https?://)?(?:www\\.)?(?:i\\.)?imgur\\.com/(?:gallery\\/)?[a-zA-Z0-9]{7}(?:\\.[a-zA-Z]{3,4})?';
my $regex = qr/(?:https?://)?(?:www\.)?(?:i\.)?imgur\.com/(?:gallery\/)?[a-zA-Z0-9]{7}(?:\.[a-zA-Z]{3,4})?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}