#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+"
Local $sString = "ORDER NUMBER : NNNN" & @CRLF & _
"" & @CRLF & _
"Ship Date: MMM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Style Desc : DDDDD" & @CRLF & _
"" & @CRLF & _
"Linecode : FFFFFF" & @CRLF & _
"" & @CRLF & _
"Qty VVVV" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ORDER NUMBER : NNNN" & @CRLF & _
"Ship Date: MMM" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Style Desc : DDDDD" & @CRLF & _
"" & @CRLF & _
"Linecode : FFFFFF" & @CRLF & _
"" & @CRLF & _
"Qty VVVV"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")