re = /ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+/
str = 'ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV
ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end