import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ORDER NUMBER :\\s+[^\\s]+\\s+Ship Date:\\s+[^\\s]+\\n\\n\\s+Style Desc : .+\\n\\s+Linecode : .+\\n\\s+Qty\\s+.+";
final String string = "ORDER NUMBER : NNNN\n\n"
+ "Ship Date: MMM\n\n\n"
+ "Style Desc : DDDDD\n\n"
+ "Linecode : FFFFFF\n\n"
+ "Qty VVVV\n\n\n"
+ "ORDER NUMBER : NNNN\n"
+ "Ship Date: MMM\n\n\n"
+ "Style Desc : DDDDD\n\n"
+ "Linecode : FFFFFF\n\n"
+ "Qty VVVV";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}