const regex = /ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ORDER NUMBER :\\s+[^\\s]+\\s+Ship Date:\\s+[^\\s]+\\n\\n\\s+Style Desc : .+\\n\\s+Linecode : .+\\n\\s+Qty\\s+.+', 'g')
const str = `ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV
ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}