$re = '/ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+/';
$str = 'ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV
ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);