// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+").unwrap();
let string = "ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV
ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}