using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ORDER NUMBER :\s+[^\s]+\s+Ship Date:\s+[^\s]+\n\n\s+Style Desc : .+\n\s+Linecode : .+\n\s+Qty\s+.+";
string input = @"ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV
ORDER NUMBER : NNNN
Ship Date: MMM
Style Desc : DDDDD
Linecode : FFFFFF
Qty VVVV";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}