use strict;
my $str = 'Apple Orange
Load Module
anApple Orange
toLoad Module
';
my $regex = qr/(?:^| )([A-Z])|./mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";