re = /(?:^| )([A-Z])|./m
str = 'Apple Orange
Load Module
anApple Orange
toLoad Module
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result