using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}";
string input = @"
kim_reel05_scn0101_shot0770
n74_reel05_scn0001_shot0700
ninehundred_reel05_scn0001_shot0700";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}