import re
regex = re.compile(r"[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}")
test_str = ("\n\n"
"kim_reel05_scn0101_shot0770\n\n"
"n74_reel05_scn0001_shot0700\n\n"
"ninehundred_reel05_scn0001_shot0700")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")