re = /[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}/
str = '
kim_reel05_scn0101_shot0770
n74_reel05_scn0001_shot0700
ninehundred_reel05_scn0001_shot0700'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end