// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}").unwrap();
let string = "
kim_reel05_scn0101_shot0770
n74_reel05_scn0001_shot0700
ninehundred_reel05_scn0001_shot0700";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}