package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z0-9]+_reel[0-9]{2}_scn[0-9]{4}_shot[]0-9]{4}`)
var str = `
kim_reel05_scn0101_shot0770
n74_reel05_scn0001_shot0700
ninehundred_reel05_scn0001_shot0700`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}