# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))/$1$4$3ay/gi;t' <<< "pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea"