#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))"
Local $sString = "pig" & @CRLF & _
"trash" & @CRLF & _
"egg" & @CRLF & _
"inbox" & @CRLF & _
"eight" & @CRLF & _
"hello" & @CRLF & _
"yahoo" & @CRLF & _
"spoonfull" & @CRLF & _
"spleen" & @CRLF & _
"flea"
Local $sSubst = "$1$4$3ay"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)