const regex = /([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))', 'gi')
const str = `pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea`;
const subst = `$1$4$3ay`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);