import re
regex = re.compile(r"([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))", flags=re.IGNORECASE)
test_str = ("pig\n"
"trash\n"
"egg\n"
"inbox\n"
"eight\n"
"hello\n"
"yahoo\n"
"spoonfull\n"
"spleen\n"
"flea")
subst = "$1$4$3ay"
result = regex.sub(subst, test_str)
if result:
print(result)