using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([aeiouy][a-z]+)|(([qwrtpsdfghjklzxcvbnm]+)([a-z]+))";
string substitution = @"$1$4$3ay";
string input = @"pig
trash
egg
inbox
eight
hello
yahoo
spoonfull
spleen
flea";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}