# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d),(\d)/\1 -> \2/;t' <<< "0:00:22.540,0:00:25.440
Hello this is a test"