use strict;
my $str = '0:00:22.540,0:00:25.440
Hello this is a test';
my $regex = qr/(\d),(\d)/p;
my $subst = '\\1 -> \\2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";