import Foundation
let pattern = #"(\d),(\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0:00:22.540,0:00:25.440
Hello this is a test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 -> \2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}