#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^\x00-\x7F]+|[a-zA-Z'-]*"
Local $sString = "Kasapović" & @CRLF & _
"Subotić" & @CRLF & _
"O'Leary" & @CRLF & _
"Müller" & @CRLF & _
"Indriðason" & @CRLF & _
"ł ą ż ź" & @CRLF & _
"Strøm" & @CRLF & _
"Särlvik" & @CRLF & _
"Mihalović-Ann"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")