package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\x00-\x7F]+|[a-zA-Z'-]*`)
var str = `Kasapović
Subotić
O'Leary
Müller
Indriðason
ł ą ż ź
Strøm
Särlvik
Mihalović-Ann`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}