re = /[^\x00-\x7F]+|[a-zA-Z'-]*/
str = 'Kasapović
Subotić
O\'Leary
Müller
Indriðason
ł ą ż ź
Strøm
Särlvik
Mihalović-Ann'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end